We’re pleased to announce that maintenance has been completed with zero downtime. As a result, you can expect significant performance improvements, even in the event of DDoS spillover.
Key enhancements include:
Reduced packet loss during DDoS leaks due to improved network handling.
Up to 15% optimization in TCP traffic performance, thanks to our transition to the BBR congestion control algorithm.
Thank you for your continued trust.
Update
May 30, 2025 at 6:30 AM
Completed
May 30, 2025 at 6:30 AM
It's not yet completed—we just need a little more time. Thank you for your patience.
Update
May 30, 2025 at 6:30 AM
Completed
May 30, 2025 at 6:30 AM
Just a little more time is needed, and the maintenance will be complete. So far, there has been zero downtime.
Completed
May 30, 2025 at 6:30 AM
Completed
May 30, 2025 at 6:30 AM
Maintenance has completed successfully
In progress
May 30, 2025 at 6:00 AM
In progress
May 30, 2025 at 6:00 AM
Maintenance is now in progress
Planned
May 30, 2025 at 6:00 AM
Planned
May 30, 2025 at 6:00 AM
We will be performing a brief maintenance on our Frankfurt core router to improve network performance and DDoS handling. This includes tuning NIC buffers, balancing CPU load, and adjusting offload features.
Impact: Minor packet loss or latency may occur briefly during the tuning process. No downtime is expected.
This is part of ongoing improvements following a recent high PPS DDoS event. No action is needed on your part.