Scheduled for February 16, 2026 at 10:00 AM – February 17, 2026 at 9:16 AM
Affects
NorthC (AMS)
Under maintenance from 10:00 AM to 9:16 AM
FRA1 (Germany)
Under maintenance from 10:00 AM to 9:16 AM
Updates
Completed
February 17, 2026 at 9:16 AM
Completed
February 17, 2026 at 9:16 AM
The maintenance has been completed successfully. The firmware has been upgraded.
Update
February 17, 2026 at 8:52 AM
Update
February 17, 2026 at 8:52 AM
It will start in ten minutes. There may be traffic flaps.
Update
February 16, 2026 at 10:08 PM
Update
February 16, 2026 at 10:08 PM
The network engineer will carry out the final maintenance tasks at 07:00 UTC on 17 February.
This may affect traffic flow.
Update
February 16, 2026 at 10:08 PM
Update
February 16, 2026 at 10:08 PM
The network engineer will perform the final maintenance tasks at 07:00 UTC on 17 February.
In progress
February 16, 2026 at 10:01 AM
In progress
February 16, 2026 at 10:01 AM
Maintenance is now in progress. We are making changes to our routing to improve connections to Poland and Telekom. Some disruption may be expected. Thank you.
Planned
February 16, 2026 at 10:00 AM
Planned
February 16, 2026 at 10:00 AM
We are planning for a scheduled maintenance during that time.